WP 2.6 fungerar som den ska efter en massa strul…

Problemen med den nya versionen är lösta. I korthet kan jag berätta vad det var som strulade:

Jag hade ställt in custom permalinks förut som: /index.php/%category%/%postname%.htm

Det ger en exempelpost denna url: http://jinge.se/index.php/allmant/exempelpost.htm

Den nya versionen av WP är ändrad så att permalänkarna i stället ska skrivas: /%category%/%postname%.htm det vill säga UTAN index.php.

När jag ändrade detta, vilket var krångligt eftersom jag inte kom åt bloggen utan att radera .htaccess, så fungerade alla gamla länkar som de skulle. Dvs en länk till min förra post såg förut ut så här: http://jinge.se/index.php/internet/wordpress-26-slappt.htm, nu är samma länk exakt likadan utan index.php.

OBS: Denna ändring påverkar inte indexering hos Google/Intressant eller andra som länkar direkt till ett blogginlägg!

Man kan givetvis säga en massa saker om att WP hade missat att meddela folk om den ändringen, men troligen så insåg de inte att tusentals bloggar skulle sluta att fungera.

Jag tänker inte skriva alla fula ord som jag har sagt i eftermiddag, men jag kan lova att de flesta av besökarna här skulle bli förvånade över mitt ordförråd.

Nu byter jag rubrik på detta inlägg och andra som drabbats av detta problem får maila mig ifall förklaringen inte är tillräckligt bra…

Andra om: , , , , , ,

i t

  9 comments for “WP 2.6 fungerar som den ska efter en massa strul…

  1. 15 juli, 2008 at 16:13

    Nu tycks permalänkarna fungera som de ska. Men jag kan inte logga in, en liten detalj bara… :-)

  2. 15 juli, 2008 at 16:42

    Fick en knapp högst uppe till höger i WordPress 2.6 som det stod Turbo på ?!?. Installera nåt som lagrar bilderna lokalt på min dator? Vad i hela världen ska det vara bra för? WordPress 2.6 verkar vara rena hjärnblödningen!

  3. 15 juli, 2008 at 17:18

    Testkommentar

  4. 15 juli, 2008 at 19:06

    @Christer:

    jag hittade den nu, vad gör den? :)

  5. 15 juli, 2008 at 22:15

    Konstigt att WP teamet inte meddelade om den ”lilla” ändringen!Jag har inte stött på problem när jag uppdaterade :-). Hoppas att det håller

  6. 16 juli, 2008 at 01:44

    Tack för hjälpen! Googlade runt eftersom jag inte fick min kommentarsfunktion att fungera efter uppgraderingen som jag ”bara skulle fixa en snabbis innan jag gick och la mig”. Några timmar senare är det äntligen löst tack vare ditt inlägg! Ändrade bara permalinksstrukturen till default så fungerar det igen!

    //Rebecca

  7. 16 juli, 2008 at 04:34

    Jag vet inte, men det verkar som om detta problem är det största av dem man hittat. Och det var inte folk från WP som hittade lösningen heller utan ngn annan.

    När jag inte kom in, eller ens fick fatt på filen som används, så tänkte jag på ett tips från ett föregående tillfälle om att eliminera .htaccess vilket förvånande nog fungerade.

    Man skröt lite från WP att man släppte 2.6 en månad tidigare än avsett, det samtidigt som man dagarna innan släppt release candidate 1. :-)

    Och jag VET att man inte ska vara het på gröten när det gäller uppdateringar, men just 2.5.1 har varit så buggig så jag kunde inte låta bli. Men men, nästa uppdatering ska jag handskas försiktigare med.

    Det största problemet denna gång har nog varit just permalänkstrukturen. Har man haft customiserad sådan så har det strulat, annars inte.

  8. 16 juli, 2008 at 04:37

    F.ö. blir jag GALEN på sådant strul. Tappa korrekta länkar till fyra års bloggande…

    :-(

  9. 16 juli, 2008 at 05:17

    Undermålig betatestning är ett bevis på att man inte tar särskilt allvarligt på sin uppgift.

Comments are closed.